Песочница

Это страница для тестирования wiki-разметки

Сначала нужно войти (справа вверху), чтобы начать править страницу…

Ссылки на форум Миста.ру

Пользователи форума

Код на 1С

У меня есть готовая подсветка для кода 1С на JavaScript. http://x-romix.narod.ru/Highlight1C.html

пока не работает!

Подсветка кода 1c8

// Процедура инициализирует глобальную переменную глТекущийПользователь.
// Переменная содержит ссылку на элемент справочника "Пользователи", 
// соответствующий текущему пользователю информационной базы.
//
// Параметры:
//  Нет.
//
Процедура ОпределитьТекущегоПользователя()

	Если ПустаяСтрока(ИмяПользователя()) Тогда
		ИмяПользователя           = "НеАвторизован";
		ПолноеИмяПользователя     = "Не авторизован";

	Иначе
		ИмяПользователя           = ИмяПользователя();

		Если ПустаяСтрока(ПолноеИмяПользователя()) Тогда
			ПолноеИмяПользователя = ИмяПользователя;
		Иначе
			ПолноеИмяПользователя = ПолноеИмяПользователя();
		КонецЕсли;
	КонецЕсли;

	глТекущийПользователь = Справочники.Пользователи.НайтиПоКоду(ИмяПользователя);

	Если глТекущийПользователь = Справочники.Пользователи.ПустаяСсылка() Тогда
		ОбъектПользователь = Справочники.Пользователи.СоздатьЭлемент();

		ОбъектПользователь.Код          = ИмяПользователя;
		ОбъектПользователь.Наименование = ПолноеИмяПользователя;

		ОбъектПользователь.Записать();

		УстановитьНастройкиПоУмолчанию(ОбъектПользователь.Ссылка);
		
		Сообщить("Пользователь зарегистрирован в справочнике пользователей.");
		глТекущийПользователь = ОбъектПользователь.Ссылка;
	КонецЕсли;

КонецПроцедуры // ОпределитьТекущегоПользователя()

Подсветка запроса

ВЫБРАТЬ
// комментарий в запросе
   Таб1.СсылкаДок,
   Таб1.ДатаДок,
   Таб1.ВалютаДок,
   Таб2.Курс,
   "какая-то строка в запросе" как ПолеСтроки
ИЗ
   (ВЫБРАТЬ
    ЗаказПокупателя.Ссылка КАК СсылкаДок,
    ЗаказПокупателя.Дата КАК ДатаДок,
    ЗаказПокупателя.ВалютаДокумента КАК ВалютаДок,
    МАКСИМУМ(Валюты.Период) КАК ПериодДок,
    ВЫБОР
      КОГДА ЗаказПокупателя.Проведен ТОГДА ИСТИНА
      ИНАЧЕ ЛОЖЬ
    КОНЕЦ КАК ПроведенДок
   ИЗ
    Документ.ЗаказПокупателя КАК ЗаказПокупателя
    ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.КурсыВалют КАК Валюты
      ПО Валюты.Период <= ЗаказПокупателя.Дата И
      Валюты.Валюта = ЗаказПокупателя.ВалютаДокумента
   ГДЕ
    ДатаДок > НачалоПериода(ДАТАВРЕМЯ(2010,1,1,0,0,0), КВАРТАЛ) 
    И ВалютаДок ЕСТЬ НЕ NULL
   СГРУППИРОВАТЬ ПО
    ЗаказПокупателя.Ссылка) КАК Таб1
    ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.КурсыВалют КАК Таб2
    ПО Таб1.ПериодДок = Таб2.Период И Таб1.ВалютаДок = Таб2.Валюта
   АВТОУПОРЯДОЧИВАНИЕ
   ИТОГИ ОБЩИЕ ПО СсылкаДок

Заголовок

Заголовок

LaTeX

$ 2+3=5 $

 I am \LaTeXe!

\begin{eqnarray*}
& & \frac{3}{4 \pi}   \sqrt{4 \cdot x^2   12}\\
& & \lim_{n \to \infty}
  \sum_{k=1}^n \frac{1}{k^2} = \frac{\pi^2}{6}\\
& & {\it f}(x) = \frac{1}{\sqrt{x} x^2}\\
& & e^{i \pi} + 1 = 0\;
\end{eqnarray*}

меня зовут Вася

А как добавить новый абзац (пунк в содержание)?

А добавить новый абзац вот так

Проверка таблицы:

Имя Код
Вася 001
Петя 002

Проверка изображений